Home  
  CompTIA  
  Practice Exams  
  TechNotes  
  - A+ Core -  
  - A+ OS -  
  - Network+ -  
  - Security+ -  
  - Linux+ -  
  Links  
  Forums  
  Blogs  
  Topsites  
  Search the Web  
  Watch free videos online  
     
  Subnet Calculator  
  Online Degrees  
  Exam Vouchers  
  Free Magazines  

   
CCNA TechLab: Configuring RIP Routing

Lab Requirements: to be able to perform the tasks in this lab you need 2 Cisco routers connected to each other. In this TechLan we assumed two 2501 routers, but pretty much set of routers will do. This lab does not cover how to physically connect the routers and the hosts, but rather assumes you can tell by looking at the diagram. If you need information on how to setup your lab physically, please refer to our Setting up the Hardware TechLab.
This lab comes in three versions, the one you are looking at, a printer-friendly version with the commands, and a printer-friendly version without the commands that can be used as an assessment. The printer-friendly versions are for members only. Also note the the commands in this lab often include the router command prompt and never use the abbreviated form.

This first CCNA TechLab covers a couple of basic configuration tasks, such as setting passwords and enabling IP routing using RIP. You will need a lab setup similar to the network diagram below:







Before you start, make sure you clear both routers' configuration using the Router#erase startup-config command. First we will configure RouterA, after the router reboots, the following message will be displayed:

% Please answer 'yes' or 'no'.
Would you like to enter the initial configuration dialog? [yes/no]


Type no and press ENTER. Press ENTER again when the message Press RETURN to get started appears. Type enable at the Router> command prompt to enter Privileged Exec mode, notice the prompt chances to Router#.


CONFIGURING THE FIRST ROUTER

STEP 1. Change the router's host name to RouterA

Enter configuration mode using the following command:
Router#configure terminal

Change the host name of the router to RouterA using the following command :
Router(config)#hostname RouterA
RouterA(config)#

Notice how changing the hostname immediately affects the prompt. Remember that you are configuring the running configuration.


STEP 2. Disable domain lookups

To prevent the router from interpreting every incorrectly typed command as a host name and trying to resolve it to an IP address to setup a telnet connection with it, use the following command:
RouterA(config)#no ip domain-lookup


STEP 3. Configure passwords

First set the enable password to cisco123 using the following command:
RouterA(config)#enable secret cisco123

Next, set the password for telnet connections to cisco456 using the following commands:
RouterA(config)#line vty 0 4
RouterA(config-line)#password cisco456
RouterA(config-line)#login


Although the enable secret command is used to encrypt the enable password, other passwords stored in the router's configuration should be encrypted as well. To do this, use the following command:
RouterA(config)#service password-encryption


STEP 4. Configuring the Ethernet interface

Enter Interface configuration mode for the Ethernet interface, using the following command:
RouterA(config)#interface Ethernet 0

Give it the description "Connected to LAN" using the following command:
RouterA(config-if)#description Connected to LAN1

Configure the IP address (see diagram for correct address) for the interface using the following command:
RouterA(config-if)#ip address 192.168.11.1 255.255.255.0

Enable the interface using the following command:
RouterA(config-if)#no shutdown


STEP 5. Configure the serial WAN interface

Switch to Interface configuration mode for the first Serial interface, using the following command:
RouterA(config)#interface Serial 0

Give it the description "Direct connection to RouterB" using the following command:
RouterA(config-if)#description connected to RouterB

Configure the IP address (see diagram for correct address) for the interface using the following command:
RouterA(config-if)#ip address 192.168.22.5 255.255.255.0

Configure the interface to use PPP encapsulation using the following command:
RouterA(config-if)#encapsulation ppp

Enable the interface using the following command:
RouterA(config-if)#no shutdown


STEP 6. Configure RIP

Use the following command to enable RIP on RouterA:
RouterA(config)#router rip

Configure the router to receive and send only RIP Version 2 packets using the following command:
RouterA(config-router)#version 2

Use the following commands to specify the networks directly connected to the router:
RouterA(config-router)#network 192.168.11.0
RouterA(config-router)#network 192.168.22.0


STEP 7. Save configuration

To copy the currently running active configuration to NVRAM, so it will be used the next time you reload the router, use the following command:
RouterA#copy running-config startup-config


STEP 8. Configuration second router


To configure the other router, RouterB, repeat the steps above. Use the network diagram to determine the correct addressing and names. To enable the back-to-back serial connection between te routers, you need to configure one router as DCE using the following command in Interface configuration mode for the serial connection on RouterB:
RouterB(config-if)#clock rate 64000


STEP 9. Verify and test the configuration

Verify using the ping command Host A to Host B, make sure you configured both hosts to use the nearest router's interface as the default gateway in the TCP/IP settings.

On both routers, run the following command in Privileged Exec mode to determine which device is the DCE:
Router#show controllers s0

On one of the routers, run the following command in Privileged Exec mode to display the parameters and current state of the active routing protocol process, and examine the output:
Router#show ip protocols

Use the following command to verify routing table entries on both routers:
Router#show ip route

Use the following command to list a summary of the interface's IP information and status on both routers, and examine the output:
Router#show ip interface

Use the same command with the brief option, and the notice output:
Router#show ip interface brief


Cisco CCNA Labs – Are you looking for additional Cisco Labs? We have Cisco CCNA Labs, Cisco CCNP Labs and Cisco Video Training that you will bring your Cisco routing & switching skills to the next level. Click Here for more Cisco Training!



Ciscokits.com – Experience the real thing, build your own lab. Free study labs and documents, command lists, router/switch procedures, lab suggestions, and more.

Discuss this Lab here
Back to the list of CCNA TechNotes & Labs
Author: Johan Hiemstra




 
 
 

All images and text are copyright protected, violations of these rights will be prosecuted to the full extent of the law.
2002-2015 TechExams.Net | Advertise | Disclaimer